Citrix XenServer multiple security updates

Today (November 13th 2012) Citrix has released a critical update for all of it’s XenServer products.

A number of security vulnerabilities have been identified in Citrix XenServer. These vulnerabilities affect all currently supported versions of Citrix XenServer up to and including version 6.1.

The following denial of service vulnerabilities have been addressed:

  • Timer overflow DoS vulnerability (CVE-2012-4535)
  • pirq range check DoS vulnerability (CVE-2012-4536)
  • Memory mapping failure DoS vulnerability (CVE-2012-4537)
  • Unhooking empty PAE entries DoS vulnerability (CVE-2012-4538)
  • Grant table hypercall infinite loop DoS vulnerability (CVE-2012-4539)
  • XENMEM_add_to_physmap DoS vulnerability (CVE-2012-4557)

What Customers Should Do

Hotfixes have been released to address these issues in all supported versions and update levels of Citrix XenServer. Citrix strongly recommends that customers using Citrix XenServer identify and apply the hotfixes that relate to their deployed versions:

Citrix XenServer 6.1:http://support.citrix.com/article/ctx135469

Citrix XenServer 6.0.2:http://support.citrix.com/article/ctx135467

Citrix XenServer 6.0.2 CC: Customers using Citrix XenServer 6.0.2 in the Common Criteria evaluated configuration should apply the following hotfixes: http://support.citrix.com/article/ctx135468

Please note that the Common Criteria Target Of Evaluation (TOE) is not affected by the vulnerabilities disclosed in this bulletin.

Citrix XenServer 6.0.0:http://support.citrix.com/article/ctx135466

Citrix XenServer 5.6 SP2:http://support.citrix.com/article/ctx135465

Citrix XenServer 5.6 FP1:http://support.citrix.com/article/ctx135464

Citrix XenServer 5.6:http://support.citrix.com/article/ctx135462

Citrix XenServer 5.6 CC: Customers using Citrix XenServer 5.6 in the Common Criteria evaluated configuration should apply the following hotfixes: http://support.citrix.com/article/ctx135463

Please note that the Common Criteria Target Of Evaluation (TOE) is not affected by the vulnerabilities disclosed in this bulletin.

Citrix XenServer 5.5 Update 2:http://support.citrix.com/article/ctx135461

Citrix XenServer 5.0 Update 3: http://support.citrix.com/article/ctx135460

Customers using Citrix CloudPlatform, previously known as Citrix CloudStack, that use XenServer are recommended to apply the hotfix relevant to their version of XenServer.

Read the entire post here.

Leave a Reply

Your e-mail address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.