Configured policies do not apply to XenApp 6.0 Worker Groups

Ever faced with the fact that your configured policies don’t apply to your Worker Groups configured in XenApp6.0?

This issue occurs if the computer policies from the Delivery Service Console are configured correctly but are not applied correctly on the Worker Groups.

The policies are reviewed from the console and it is configured correctly.

Policy settings are stored in the following locations:

  • 32-bit component Registry location HKLMSoftwarePoliciesCitrix
  • 64-bit component Registry location HKLMSoftwareWow6432NodePoliciesCitrix

The registry key EvidenceServerGroup contains the names of the Worker Groups to which the policies apply.

This can be caused by the fact that a Worker Group has been renamed and the renaming did not update correctly in the registry key (EvidenceServerGroup) or the name of the Worker Group isn’t entered correctly when configuring the policy.

Resolution

Complete one of the following appropriate resolutions to resolve the issue:

If the Worker Group is renamed

Delete the Worker Group and create a new one.

If the Worker Group name is entered incorrectly

Check that the name on the registry key EvidenceServerGroup is the same that is applied policies.

Note: The Worker Group name is case-sensitive. The white space, if any, in the name must be entered exactly the same way while configuring policy.

Read the original article here.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.