Vulnerability in Citrix Receiver with Online Plug-in for Windows could result in arbitrary code execution

Citrix has released today this medium security vulnerability article.

Description of Problem

A vulnerability has been identified in the Citrix Receiver with Online Plug-in for Windows that could potentially allow an attacker to execute arbitrary code on the client device in the context of the currently logged in user.

This vulnerability is present in all versions of the Citrix Receiver for Windows up to and including version 3.2 and all versions of the Citrix Online Plug-in for Windows up to and including version 12.1.

This vulnerability has been assigned the following CVE:

• CVE-2012-4603

What Customers Should Do

This vulnerability has been addressed in the following products:

• The Citrix Receiver for Windows version 3.3 with Online Plug-in for Windows version 13.3 and later

• Version 12.3 of the Citrix Online Plug-in for Windows.

Citrix recommends that customers upgrade their Citrix Receivers and Online Plug-ins to these versions and later. These new versions can be obtained from the following location:

https://www.citrix.com/English/ss/downloads/results.asp?productID=1689163

Mitigating Factors

To conduct a successful exploit, an attacker would have to convince a user to manually lauch a specially crafted malicious file from an SMB or WebDAV fileserver. Deployments that prevent connections to potentially untrustworthy fileservers will be less exposed to this vulnerability.

Read the entire post here.